Announcement

Collapse
No announcement yet.

Turbo Miata Powerband not smooth

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Turbo Miata Powerband not smooth

    Hey everyone,

    Some quick general info: 2004 Miata with MS3 Pro, 550cc deatschwerks injectors, BKR7E plugs with NGK wires, FM Turbo kit w/ 2554r.

    I'm not sure the best wording to describe this issue, and as such I haven't been able to find much info when searching google/forums.

    At above ~4k RPM, my power output becomes unstable. The picture attached is with smoothing at 3. In this particular run I am using EBC, but the problem also exists when just running wastegate pressure.

    The spark plugs are BKR7E and have been gapped to about .025" Both the plugs and wires are new. The BKR7E were the second set of spark plugs I tried, which should rule out spark plugs as the culprit.

    If anyone has some good resources or any knowledge they could share, I would really appreciate it. I'd like to be able to go back to the dyno with a couple tools in-hand to fix this issue.

    Thanks!

    Dyno-1.jpg

    I also have a datalog of this run, but I'm not sure that I can upload that here.
    sigpic

  • #2
    What does your AFR look like? How's your fuel pump?

    Comment


    • #3
      I would think it could be a tuning issue. Who's tune are you running? Did you buy the kit from FM? If so, call them. If not, they still might help you. Lastly, the Miataturbo sight is full of FI experts and you'll probably get better answers there.
      Sean O
      2017 Ford Raptor, 1998 Wrangler, 2013 PRHT Club Edition 2.5/ Fab9/ Ohlins, KTM 1190 Adventure

      Comment


      • #4
        MiataTurbo maybe able to help a lot, but here are some basic questions that anyone will need:

        Is is only RPM based. Aka can you go above 4K with little or no boost?
        What are your AFRs?

        My guess would be with KFJ, and thinking fuel related, maybe failing fuel pump.

        My other guess would be coil packs. But I know when my "coil packs" were failing, the car would be undrivable at those ranges, where based on your graph the car still making power and moving just badly.

        Your logs or AFRs during the run would rule our a lot of things.
        1988 323 GTX--- The toy now :D
        2008 Mazdaspeed 3::SOLD ----- 1991 BRG NA8 Swap, Turbo::SOLD

        Comment


        • #5
          Did you happen to log AFR?
          The only thing that oughta be hella flushed is a toilet.
          http://www.miataramblings.blogspot.com

          Comment


          • #6
            The tune was done by Steven Kan. He was unable to tune it out, and suggested it must be something hardware related.

            I will upload the log file and my tune when I get home. I believe the AFRs were at about 11.5 the whole way through. Which is probably a bit rich, but I don't think that richness would cause this issue.

            And yeah I will post up on MT.net if I need to, I just wanted to post here first and get all my dumb questions out of the way so they don't roast me :)
            sigpic

            Comment


            • #7
              Is that really that choppy? Looking at FM's own dyno graphs they all seem to have that effect up top.

              How does the car feel ​when you drive it?



              sigpic

              Comment


              • #8
                Good contextual info.

                If you look at the 2554 dyno on the last FM graph compared to his, he has a pretty decent torque plateau.

                Comment


                • #9
                  https://www.corvetteforum.com/forums...dyno-line.html

                  It's basically instrumentation error that can be smoothed, probably via RMS - if it doesn't feel jerky on the road, don't worry about it.

                  Comment


                  • #10
                    Nick, that's good info to have.

                    Iscariot, thanks for the link.

                    The car feels fine. When on the dyno, you can see the dips by looking at the engine/front wheel. It was enough motion to get Dyno Dave's attention, at least. If this is not a big concern, and somewhat common, then I feel okay with it. I just hadn't noticed any graphs like this before.

                    Here is a link to download my current tune, as well as the log from this run.
                    Last edited by CAKELIE; 10-12-2017, 06:49 PM.
                    sigpic

                    Comment


                    • #11
                      Ha. Assumed you were talking about a feeling, not the actual graph!
                      Sean O
                      2017 Ford Raptor, 1998 Wrangler, 2013 PRHT Club Edition 2.5/ Fab9/ Ohlins, KTM 1190 Adventure

                      Comment


                      • #12
                        Originally posted by carnut169 View Post
                        Ha. Assumed you were talking about a feeling, not the actual graph!
                        Ah, I should have clarified. After reading all these responses and looking at some more turbo miata dyno runs, it does seem that this is somewhat normal.

                        Thanks everyone for the input!
                        sigpic

                        Comment

                        Working...
                        X