Announcement

Collapse
No announcement yet.

Popping Sound...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Popping Sound...

    I have a weird popping sound every time I hit the brakes. It's just a pop. It sounds like it's coming from the left front, I can't see anything visibly wrong though. Any clues what to check?

  • #2
    Last time I had something like that happen, one of the bolts on the front sway bar mount was loose and the metal retainer for the bushing was hopping around on the threads.

    Originally posted by miata5620
    Eric's Garage ... You buy all the parts I tell you to and you will have a killer car... If you want other parts used your car will suck and it will cost you more...

    Comment


    • #3
      Yeah, just saw I broke another sway bar mount lol.

      Comment


      • #4
        Well there ya go then. :D

        Originally posted by miata5620
        Eric's Garage ... You buy all the parts I tell you to and you will have a killer car... If you want other parts used your car will suck and it will cost you more...

        Comment


        • #5
          I need to find out why I keep twisting them.

          Comment


          • #6
            Can you get a picture of how they are breaking? OEM bar? Bushing condition?

            Originally posted by miata5620
            Eric's Garage ... You buy all the parts I tell you to and you will have a killer car... If you want other parts used your car will suck and it will cost you more...

            Comment


            • #7
              It's a Flyin Miata bar, the bushings are brand new, it's only breaking the driver side, so it seems something is binding up or something, I will get a pic, but the mount literally bends, and the bushing falls out...lol

              Comment


              • #8
                Stupid question, but to cover all the angles, you are using the brackets (or the same size brackets) that came with the bar correct?

                If so, maybe look into something along these lines then: http://www.flyinmiata.com/index.php?...umber=13-36600
                I remember these being discussed at length on one of the forums, but basically some people have seen the mounts come off the car, or they just break like your case. These mounts are supposed to cure that issue. Nick (nickt93) has them on his '95 currently, IDK if he was having an issue or not though.

                Originally posted by miata5620
                Eric's Garage ... You buy all the parts I tell you to and you will have a killer car... If you want other parts used your car will suck and it will cost you more...

                Comment


                • #9
                  Yeah I was looking at getting some of those, I guess that's my only option to fix it properly. Thanks!

                  Comment


                  • #10
                    No problem. I just got an FM bar, hasn't seen any road use on my car yet, so I'm going to be keeping an extra close eye on that area since I've been seeing more and more issues pop up online.

                    Originally posted by miata5620
                    Eric's Garage ... You buy all the parts I tell you to and you will have a killer car... If you want other parts used your car will suck and it will cost you more...

                    Comment


                    • #11
                      Weird, how come it seems to happen with their bar more than others? Doesn't sound like a simple case of over tightening.

                      Comment


                      • #12
                        Yeah I haven't over tightened it, double checked, not sure why it happens.

                        Comment


                        • #13
                          Maybe their bars overpower the frame? :lol:

                          Originally posted by miata5620
                          Eric's Garage ... You buy all the parts I tell you to and you will have a killer car... If you want other parts used your car will suck and it will cost you more...

                          Comment


                          • #14
                            I'm running the Racing Beat 1.125" front bar (not that ***** 1" FM bar) and using the Mazdaspeed mounts. They were a freaking ***** to install, but comparing the before and after, there's nothing to compare. Beefy!
                            Friday nights 7-9 PM, go to www.ksuradio.com and listen to Owl Oldies. Visit our Facebook group for any requests and suggestions. Classic Kevin - 60s and 70s on OWL Radio

                            Comment


                            • #15
                              ^Well aren't you mister cool...

                              Comment

                              Working...
                              X