Results 1 to 6 of 6

Thread: Poly bushing squeak

  1. #1
    Join Date
    Apr 2013
    Posts
    594

    Default Poly bushing squeak

    First cold snap, now I know what everyone is saying about they squeak. Previous owner did install zerk fittings. What do I grease them with? Car feels super tight, but I dont know if I would have poly installed if I had a choice.

  2. #2
    Join Date
    Mar 2009
    Posts
    1,161

    Default

    SuperLube is what I use in mine. You don't want to use any grease that's petroleum based that'll attack the poly. You can snag a tube of it that'll fit into a grease gun - I use this mini-grease setup just cuz. https://www.amazon.com/Super-Lube-21...RFN0Y2XH1AYJSM

  3. #3
    Join Date
    Jan 2012
    Location
    Marietta
    Posts
    726

    Default

    I use Super lube in a grease gun. You can get it on Amazon.

    Super Lube 41150 Synthetic Grease (NLGI 2), 14.1 oz Cartridge https://www.amazon.com/dp/B0042FG74W/ref=cm_sw_r_cp_apa_woO9zbKK0VCMY
    '00 Silver Miata

  4. #4
    Join Date
    Jan 2012
    Location
    Marietta
    Posts
    726

    Default

    Haha! Got distracted while posting. ����
    '00 Silver Miata

  5. #5
    Join Date
    Apr 2013
    Posts
    594

    Default

    Thanks guys. So you had the same problem when it got cold? Also when I let the car off the jackstands, it stays raised up until I drive it, and the suspension settles back down. Normal,correct?

  6. #6
    Join Date
    Jan 2012
    Location
    Marietta
    Posts
    726

    Default

    The easiest and best solution is to buy Sadfab's bronze sleeves for the poly bushings. They act as a bearing to remove the stiction caused by the grease getting washed out.
    '00 Silver Miata

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •